DeviceFilters

ElementMissed InstructionsCov.Missed BranchesCov.MissedCxtyMissedLinesMissedMethods
Total109 of 1090%8 of 80%202021211616
or(Predicate[])130%20%223311
or(Collection)130%20%223311
and(Predicate[])130%20%223311
and(Collection)130%20%223311
ofType(DeviceType)60%n/a112211
lambda$and$8(Collection, Device)60%n/a112211
lambda$and$6(Predicate[], Device)60%n/a112211
lambda$or$4(Collection, Device)60%n/a112211
lambda$or$2(Predicate[], Device)60%n/a112211
lambda$ofType$0(DeviceType, Device)50%n/a112211
lambda$and$7(Device, Predicate)40%n/a111111
lambda$and$5(Device, Predicate)40%n/a111111
lambda$or$3(Device, Predicate)40%n/a111111
lambda$or$1(Device, Predicate)40%n/a111111
ofGPU()30%n/a111111
ofCPU()30%n/a111111